CVE-2013-1821 ruby1.9.1

Metadata

medium
5.0
ruby1.9.1
CVE-2013-1821
2017-12-29 23:00
ALAS-2013-173
ALAS-2013-195
Moderate CentOS ruby Update
CVE-2013-1821 ruby1.8
CVE-2013-1821
2017-12-29 21:03
2017-06-16 19:03
2017-04-01 19:11
2017-01-05 20:16

Description

lib/rexml/text.rb in the REXML parser in Ruby before 1.9.3-p392 allows remote attackers to cause a denial of service (memory consumption and crash) via crafted text nodes in an XML document, aka an XML Entity Expansion (XEE) attack.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
wheezy ruby1.9.1 1.9.3.194-8.1+deb7u1