CVE-2004-1388 gpsd

Metadata

high
7.5
gpsd
CVE-2004-1388
2017-06-18 07:04
CVE-2004-1388
2017-06-16 18:43
2017-04-01 19:11
2017-01-05 20:16

Description

Format string vulnerability in the gpsd_report function for BerliOS GPD daemon (gpsd, formerly pygps) 1.9.0 through 2.7 allows remote attackers to execute arbitrary code via certain GPS requests containing format string specifiers that are not properly handled in syslog calls.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
buster gpsd 2.7-4
jessie gpsd 2.7-4
sid gpsd 2.7-4
stretch gpsd 2.7-4
wheezy gpsd 2.7-4