CVE-2013-1840 glance

Metadata

low
3.5
glance
CVE-2013-1840
2017-11-10 05:03
CVE-2013-1840
2017-08-20 17:03
2017-06-18 07:04
2017-06-16 19:03
2017-04-01 19:11
2017-01-05 20:16

Description

The v1 API in OpenStack Glance Essex (2012.1), Folsom (2012.2), and Grizzly, when using the single-tenant Swift or S3 store, reports the location field, which allows remote authenticated users to obtain the operator's backend credentials via a request for a cached image.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
buster glance 2012.1.1-5
jessie glance 2012.1.1-5
sid glance 2012.1.1-5
stretch glance 2012.1.1-5
wheezy glance 2012.1.1-5