CVE-2011-4319

Metadata

medium
4.3
rails, ruby-actionpack-2.3
CVE-2011-4319
cve.mitre.org, openwall.com
2011-11-28
2017-06-16 18:58
CVE-2011-4319 rails
XSS vulnerability in the translate helper method in Ruby on Rails
2017-05-10 23:23
2017-04-14 09:58
2017-04-01 21:24
2017-01-05 19:51

Description

Cross-site scripting (XSS) vulnerability in the i18n translations helper method in Ruby on Rails 3.0.x before 3.0.11 and 3.1.x before 3.1.2, and the rails_xss plugin in Ruby on Rails 2.3.x, allows remote attackers to inject arbitrary web script or HTML via vectors related to a translations string whose name ends with an "html" substring.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

None

Unaffected

Release Package Reason
hardy rails ignored
ruby-actionpack-2.3 DNE
lucid rails ignored
ruby-actionpack-2.3 DNE
maverick rails ignored
ruby-actionpack-2.3 DNE
natty rails ignored
ruby-actionpack-2.3 DNE
oneiric rails not-affected
ruby-actionpack-2.3 ignored
precise rails not-affected
ruby-actionpack-2.3 ignored
precise/esm rails DNE
ruby-actionpack-2.3 DNE
quantal rails not-affected
ruby-actionpack-2.3 ignored
raring rails not-affected
ruby-actionpack-2.3 ignored
saucy rails not-affected
ruby-actionpack-2.3 ignored
trusty rails not-affected
ruby-actionpack-2.3 DNE
utopic rails not-affected
ruby-actionpack-2.3 DNE
vivid rails not-affected
ruby-actionpack-2.3 DNE
vivid/stable-phone-overlay rails DNE
ruby-actionpack-2.3 DNE
vivid/ubuntu-core rails DNE
ruby-actionpack-2.3 DNE
wily rails not-affected
ruby-actionpack-2.3 DNE
xenial rails not-affected
ruby-actionpack-2.3 DNE
yakkety rails not-affected
ruby-actionpack-2.3 DNE
zesty rails not-affected
ruby-actionpack-2.3 DNE
devel rails not-affected
ruby-actionpack-2.3 DNE

Needs Triage

Release Package Reason
upstream rails needs-triage