CVE-2017-5053

Metadata

medium
6.8
chromium-browser, oxide-qt, libv8-3.14, libv8
CVE-2017-5053
cve.mitre.org, chromereleases.googleblog.com
2017-10-27
2017-11-13 20:36
CVE-2017-5053 libv8
CVE-2017-5053 chromium-browser
2017-11-06 22:04
2017-11-01 14:03
2017-10-30 16:24
2017-10-23 14:15
2017-07-20 21:29
2017-06-15 17:12
2017-05-10 23:46
2017-04-26 19:04
2017-04-14 10:19
2017-04-01 21:42
2017-03-31 01:03

Description

An out-of-bounds read in V8 in Google Chrome prior to 57.0.2987.133 for Linux, Windows, and Mac, and 57.0.2987.132 for Android, allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page, related to Array.prototype.indexOf.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
artful chromium-browser 58.0.3029.81-0ubuntu2.1350
oxide-qt None
devel chromium-browser 58.0.3029.81-0ubuntu2.1350
trusty chromium-browser 58.0.3029.81-0ubuntu0.14.04.1172
oxide-qt None
upstream chromium-browser 57.0.2987.133
libv8-3.14 None
xenial chromium-browser 58.0.3029.81-0ubuntu0.16.04.1277
oxide-qt None
yakkety chromium-browser 58.0.3029.81-0ubuntu0.16.10.1345
zesty chromium-browser 58.0.3029.81-0ubuntu2.17.04.1350
oxide-qt None

Unaffected

Release Package Reason
precise chromium-browser ignored
oxide-qt DNE
libv8 ignored
libv8-3.14 DNE
precise/esm chromium-browser DNE
oxide-qt DNE
libv8 DNE
libv8-3.14 DNE
vivid/ubuntu-core chromium-browser DNE
oxide-qt DNE
libv8 DNE
libv8-3.14 DNE
vivid/stable-phone-overlay chromium-browser DNE
oxide-qt ignored
libv8 DNE
libv8-3.14 DNE
yakkety oxide-qt ignored
libv8 DNE
libv8-3.14 ignored
devel oxide-qt DNE
libv8 DNE
trusty libv8 DNE
xenial libv8 DNE
zesty libv8 DNE
artful libv8 DNE

Needs Triage

Release Package Reason
upstream oxide-qt needs-triage
libv8 needs-triage
trusty libv8-3.14 needs-triage
xenial libv8-3.14 needs-triage
zesty libv8-3.14 needs-triage
artful libv8-3.14 needs-triage
devel libv8-3.14 needs-triage