CVE-2017-2428

Metadata

high
7.5
nghttp2
CVE-2017-2428
cve.mitre.org, github.com, support.apple.com, support.apple.com, support.apple.com, support.apple.com
2017-04-01
2017-10-23 14:17
2017-07-20 21:30
2017-06-16 19:21
2017-05-10 23:47
2017-04-14 10:20
2017-04-04 02:03

Description

An issue was discovered in certain Apple products. iOS before 10.3 is affected. macOS before 10.12.4 is affected. tvOS before 10.2 is affected. watchOS before 3.2 is affected. The issue involves nghttp2 before 1.17.0 in the "HTTPProtocol" component. It allows remote HTTP/2 servers to have an unspecified impact via unknown vectors.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

None

Unaffected

Release Package Reason
precise nghttp2 DNE
precise/esm nghttp2 DNE
trusty nghttp2 DNE
vivid/stable-phone-overlay nghttp2 DNE
vivid/ubuntu-core nghttp2 DNE
yakkety nghttp2 ignored
zesty nghttp2 not-affected
artful nghttp2 not-affected
devel nghttp2 not-affected

Needs Triage

Release Package Reason
upstream nghttp2 needs-triage
xenial nghttp2 needs-triage