CVE-2017-7875

Metadata

high
7.5
feh
CVE-2017-7875
cve.mitre.org, feh.finalrewind.org, github.com, bugs.debian.org
2017-04-14
2017-10-23 14:20
CVE-2017-7875 feh
2017-07-20 21:31
2017-06-16 19:22
2017-05-10 23:49
2017-04-17 19:03

Description

In wallpaper.c in feh before v2.18.3, if a malicious client pretends to be the E17 window manager, it is possible to trigger an out-of-boundary heap write while receiving an IPC message. An integer overflow leads to a buffer overflow and/or a double free.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
trusty feh None
upstream feh 2.18-2
xenial feh None
zesty feh None

Unaffected

Release Package Reason
precise feh ignored
precise/esm feh DNE
vivid/stable-phone-overlay feh DNE
vivid/ubuntu-core feh DNE
yakkety feh ignored

Needs Triage

Release Package Reason
artful feh needs-triage
devel feh needs-triage