CVE-2016-10345

Metadata

medium
4.6
passenger
CVE-2016-10345
cve.mitre.org, github.com, github.com
2017-04-18
2017-10-23 14:20
CVE-2016-10345 passenger
Predictable tmp File Path Vulnerability in Phusion Passenger
2017-07-20 21:32
2017-06-16 19:17
2017-05-10 23:50
2017-04-20 05:06

Description

In Phusion Passenger before 5.1.0, a known /tmp filename was used during passenger-install-nginx-module execution, which could allow local attackers to gain the privileges of the passenger user.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
xenial passenger None
zesty passenger None

Unaffected

Release Package Reason
precise passenger ignored
precise/esm passenger DNE
trusty passenger DNE
vivid/stable-phone-overlay passenger DNE
vivid/ubuntu-core passenger DNE
yakkety passenger ignored

Needs Triage

Release Package Reason
upstream passenger needs-triage
artful passenger needs-triage
devel passenger needs-triage