CVE-2017-8284

Metadata

medium
6.9
qemu-kvm, qemu
CVE-2017-8284
cve.mitre.org, bugs.chromium.org
2017-04-26
2017-06-16 19:22
CVE-2017-8284 qemu-kvm
CVE-2017-8284 qemu
2017-05-10 23:55
2017-05-09 22:03
2017-04-27 20:03

Description

** DISPUTED ** The disas_insn function in target/i386/translate.c in QEMU before 2.9.0, when TCG mode without hardware acceleration is used, does not limit the instruction size, which allows local users to gain privileges by creating a modified basic block that injects code into a setuid program, as demonstrated by procmail. NOTE: the vendor has stated "this bug does not violate any security guarantees QEMU makes."

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

None

Unaffected

Release Package Reason
precise qemu-kvm ignored
qemu DNE
precise/esm qemu-kvm ignored
qemu DNE
trusty qemu-kvm DNE
qemu ignored
vivid/ubuntu-core qemu-kvm DNE
qemu DNE
vivid/stable-phone-overlay qemu-kvm DNE
qemu DNE
xenial qemu-kvm DNE
qemu ignored
yakkety qemu-kvm DNE
qemu ignored
zesty qemu-kvm DNE
qemu ignored
devel qemu-kvm DNE
qemu ignored

Needs Triage

Release Package Reason
upstream qemu-kvm needs-triage
qemu needs-triage