CVE-2017-7484

Description

It was found that some selectivity estimation functions in PostgreSQL before 9.2.21, 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, and 9.6.x before 9.6.3 did not check user privileges before providing information from pg_statistic, possibly leaking information. An unprivileged attacker could use this flaw to steal some information from tables they are otherwise not allowed to access.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
precise/esm postgresql-9.1 None
trusty postgresql-9.1 None
postgresql-9.3 9.3.17-0ubuntu0.14.04
upstream postgresql-9.1 None
postgresql-9.3 None
postgresql-9.5 9.5.7
postgresql-9.6 9.6.3
xenial postgresql-9.5 9.5.7-0ubuntu0.16.04
zesty postgresql-9.6 9.6.3-0ubuntu0.17.04

Unaffected

Release Package Reason
precise/esm postgresql-9.6 DNE
postgresql-9.5 DNE
postgresql-9.3 DNE
trusty postgresql-9.6 DNE
postgresql-9.5 DNE
vivid/ubuntu-core postgresql-9.6 DNE
postgresql-9.5 DNE
postgresql-9.3 DNE
postgresql-9.1 DNE
vivid/stable-phone-overlay postgresql-9.6 DNE
postgresql-9.5 DNE
postgresql-9.3 DNE
postgresql-9.1 DNE
xenial postgresql-9.6 DNE
postgresql-9.3 DNE
postgresql-9.1 DNE
yakkety postgresql-9.6 DNE
postgresql-9.5 ignored
postgresql-9.3 DNE
postgresql-9.1 DNE
artful postgresql-9.6 not-affected
postgresql-9.5 DNE
postgresql-9.3 DNE
postgresql-9.1 DNE
devel postgresql-9.6 not-affected
postgresql-9.5 DNE
postgresql-9.3 DNE
postgresql-9.1 DNE
zesty postgresql-9.5 DNE
postgresql-9.3 DNE
postgresql-9.1 DNE