CVE-2017-8798

Description

Integer signedness error in MiniUPnP MiniUPnPc v1.4.20101221 through v2.0 allows remote attackers to cause a denial of service or possibly have unspecified other impact.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
devel miniupnpc 1.9.20140610-3ubuntu1
trusty miniupnpc 1.6-3ubuntu2.14.04.3
upstream miniupnpc 1.9.20140610-3
xenial miniupnpc 1.9.20140610-2ubuntu2.16.04.1
yakkety miniupnpc 1.9.20140610-2ubuntu2.16.10.1
zesty miniupnpc 1.9.20140610-2ubuntu2.17.04.1

Unaffected

Release Package Reason
precise/esm miniupnpc DNE
vivid/stable-phone-overlay miniupnpc DNE
vivid/ubuntu-core miniupnpc DNE