CVE-2017-7478

Metadata

medium
5.0
openvpn
CVE-2017-7478
cve.mitre.org, community.openvpn.net, ubuntu.com, launchpad.net
2017-05-11
2017-06-16 18:42
v3.6/main/openvpn-2.4.2-r0
v3.5/main/openvpn-2.3.15-r0
CVE-2017-7478 openvpn
2017-06-15 02:36
2017-05-22 17:03
2017-05-18 04:04
2017-05-11 17:03
2017-05-11 16:03

Description

OpenVPN version 2.3.12 and newer is vulnerable to unauthenticated Denial of Service of server via received large control packet. Note that this issue is fixed in 2.3.15 and 2.4.2.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
upstream openvpn 2.4.0-5
zesty openvpn 2.4.0-4ubuntu1.2

Unaffected

Release Package Reason
precise openvpn not-affected
precise/esm openvpn not-affected
trusty openvpn not-affected
vivid/stable-phone-overlay openvpn not-affected
vivid/ubuntu-core openvpn DNE
xenial openvpn not-affected
yakkety openvpn not-affected
devel openvpn not-affected