OpenVPN versions before 2.3.15 and before 2.4.2 are vulnerable to reachable assertion when packet-ID counter rolls over resulting into Denial of Service of server by authenticated attacker.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
precise/esm openvpn None
trusty openvpn 2.3.2-7ubuntu3.2
upstream openvpn 2.4.0-5
xenial openvpn 2.3.10-1ubuntu2.1
yakkety openvpn 2.3.11-1ubuntu2.1
zesty openvpn 2.4.0-4ubuntu1.2


Release Package Reason
precise openvpn ignored
vivid/stable-phone-overlay openvpn ignored
vivid/ubuntu-core openvpn DNE
artful openvpn not-affected
devel openvpn not-affected