CVE-2017-7478 openvpn

Metadata

medium
5.0
openvpn
CVE-2017-7478
2017-06-18 07:52
v3.6/main/openvpn-2.4.2-r0
v3.5/main/openvpn-2.3.15-r0
CVE-2017-7478
2017-06-16 18:42
2017-05-27 05:03
2017-05-17 05:03
2017-05-14 17:03
2017-05-11 23:03
2017-05-11 21:03
2017-05-11 17:03

Description

OpenVPN version 2.3.12 and newer is vulnerable to unauthenticated Denial of Service of server via received large control packet. Note that this issue is fixed in 2.3.15 and 2.4.2.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
buster openvpn 2.4.0-5
sid openvpn 2.4.0-5
stretch openvpn 2.4.0-5

Unaffected

Release Package Reason
jessie openvpn
wheezy openvpn