CVE-2017-7479 openvpn


OpenVPN versions before 2.3.15 and before 2.4.2 are vulnerable to reachable assertion when packet-ID counter rolls over resulting into Denial of Service of server by authenticated attacker.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
buster openvpn 2.4.0-5
jessie openvpn 2.3.4-5+deb8u2
sid openvpn 2.4.0-5
stretch openvpn 2.4.0-5
wheezy openvpn 2.2.1-8+deb7u4