CVE-2017-8921 flightgear

Metadata

medium
5.0
flightgear
CVE-2017-8921
2017-07-22 13:03
CVE-2017-8921
2017-06-18 07:52
2017-06-16 18:42
2017-05-28 05:03
2017-05-22 05:03
2017-05-19 23:03
2017-05-14 05:03
2017-05-12 23:03

Description

In FlightGear before 2017.2.1, the FGCommand interface allows overwriting any file the user has write access to, but not with arbitrary data: only with the contents of a FlightGear flightplan (XML). A resource such as a malicious third-party aircraft could exploit this to damage files belonging to the user. Both this issue and CVE-2016-9956 are directory traversal vulnerabilities in Autopilot/route_mgr.cxx - this one exists because of an incomplete fix for CVE-2016-9956.

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
buster flightgear 1:2016.4.4+dfsg-3
jessie flightgear 3.0.0-5+deb8u2
sid flightgear 1:2016.4.4+dfsg-3
stretch flightgear 1:2016.4.4+dfsg-3