CVE-2017-9053 dwarfutils

Metadata

high
7.5
dwarfutils
CVE-2017-9053
2017-07-22 13:03
CVE-2017-9053
2017-06-23 05:03
2017-06-18 11:03
2017-06-18 07:52
2017-06-16 18:42
2017-05-26 05:03
2017-05-19 05:03
2017-05-18 11:03

Description

An issue, also known as DW201703-005, was discovered in libdwarf 2017-03-21. A heap-based buffer over-read in _dwarf_read_loc_expr_op() is due to a failure to check a pointer for being in bounds (in a few places in this function).

Am I vulnerable?

The constraints below list the versions that this vulnerability is patched in, and versions that are unaffected. If a patch is ready but unrealeased, then it is pending.

Or, you can just let us figure it out for you! Appcanary continously monitor your installed packages, and tell you if any of them are vulnerable.

Sign up for monitoring

Affected package information

Release Package Patched in
buster dwarfutils 20170416-2
jessie dwarfutils None
sid dwarfutils 20170416-2
stretch dwarfutils 20161124-1+deb9u1
wheezy dwarfutils None